Xcode5でDeploymentTargetを変更する方法

Xcode5で新規プロジェクトを作るとDeploymentTargetが7.0になっています。
まぁそれはいいんですけど、さすがに7.0以降しか対応しないアプリはまだ時期尚早だと思うので、6.0とかに変更したいのですがプルダウンからは7.0しか選択出来ず。。。

どーしたらいいんだよ〜〜〜!
アップルをちょっと憎たらしく思いながら調べてみると、どうやら対象のアーキテクチャにarm64が入っている時は64bit対応の7.0以降しか選択できないようになっているみたいです。

Build SettingsのArchitecturesを「Standard architectures(armv7,armv7s)」に変更すると昔のOSをDeploymentTargetで選択できるようになりました。
よかったよかった。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です